13 | Документация

Вкладка Редактирование

Вкладка Редактирование включает в себя (см. Рисунок 647 ):
  • переопределение списка инструментов редактирования;
  • переопределение настроек редактирования:
    • Включить автосохранение ;
    • Показывать всплывающее окно при завершении операций ;
    • Показывать модальное окно в процессе сохранения на сервер ;
    • Задать название кнопке создания объектов .
    • Рисунок 647 - Инструменты и настройка карты. Вкладка Редактирование

Переопределение списка инструментов редактирования

При добавлении всей панели инструментов Редактирование на карту по умолчанию добавляются все доступные инструменты редактирования (см. п. 9 ).
В горизонтальной вкладке Редактирование вкладки Инструменты и настройка карты отметьте опцию Переопределить список инструментов редактирования , чтобы настроить отображение списка инструментов в панели Редактирование на карте. Отключите неиспользуемые инструменты, нажимая на их иконки (см. Рисунок 648 ):
  • Сдвиг и редактирование узлов объекта ;
  • Поворот и изменение размера объекта ;
  • Создание объектов ;
  • Загрузка данных из файла ;
  • Калькулятор поля ;
  • Присоединение геометрии ;
  • Удаление объектов .
  • Рисунок 648 - Переопределение набора инструментов Редактирование

Переопределение настроек редактирования

В горизонтальной вкладке Редактирование вкладки Инструменты и настройка карты вы можете переопределить следующие настройки редактирования по умолчанию:
  • Включить автосохранение ;
    По умолчанию опция отмечена. Все изменения, вносимые при работе с картой, автоматически сохраняются на ГИС-сервере.
    Отключите опцию, чтобы пользователь сохранял изменения вручную. При этом убедитесь, что кнопка Сохранить из панели Сохранение изменений добавлена на карту (см. п. 9 ). Обратите внимание, что несохраненные изменения будут утеряны при обновлении интерактивной карты.
  • Показывать всплывающее окно при завершении операций ;
    По умолчанию опция отмечена. После создания объекта, после сохранения изменений, после завершения работы инструментов геообработки и пр. в правом верхнем углу всплывает сообщение о результатах: с зеленой галочкой - завершено успешно (см. Рисунок 649 ); с красным восклицательным знаком - завершено с ошибкой.
    Отключите опцию, если всплывающее сообщение не требуется.
  • Рисунок 649 - Пример всплывающего сообщения при успешном сохранении изменений
  • Показывать модальное окно в процессе сохранения на сервер - закрывать вручную , закрывать автоматически по завершению ;
    По умолчанию опция отключена.
    Отметьте опцию, чтобы в процессе сохранения созданного объекта, изменений при редактировании объектов, вложений, связанных объектов на ГИС-сервер отображалось модальное окно с сообщением Подождите, идёт сохранение информации на сервер .
    Выберите, когда закрывать модальное окно: вручную (выбрано по умолчанию) или автоматически по завершению. Если выбрано закрывать вручную , то после завершения процесса сохранения на ГИС-сервере отобразится модальное окно с сообщением Сохранение информации на сервер завершено и пользователю необходимо вручную его закрыть (см. Рисунок 650 ).
  • Рисунок 650 - Модальные окна в процессе сохранения информации на ГИС-сервер
  • Задать название кнопке создания объектов .
Опция позволяет определить название кнопке создания объектов.
По умолчанию опция отключена. Кнопка отображается без названия, только с иконкой.
Отметьте опцию и укажите название при необходимости (см. Рисунок 651 ).
Рисунок 651 - Название кнопки создания объектов